The combination of upgrading to iOS 10 and installing the latest carrier updates appears to be causing issues for some T-Mobile and Telstra customers in the United States and Australia respectively, crowdsourced information suggests.

A number of T-Mobile and MetroPCS customers claim that once their iPhone loses service temporarily, the device is unable to reestablish a cellular connection unless it is fully restarted or network settings are reset. The issue appears to have started after the latest 25.1 carrier update on iPhones running iOS 10.

MacRumors reader GCHASE1995:

Anyone on T-Mobile that has done the carrier update to 25.1, have you been getting no service? I can’t get service at all. I can get it, if I reset network settings. Then if I lose service I can’t get it back.

Reddit user Hitokill:

I am in the same boat as many others. If I can stay connected to the LTE network the 25.1 update is fine. However, I work in a building with certain areas that have no coverage. Once I walk in those areas and lose signal, then walk to an area where I normally have full bars I can’t get it back on no matter what I do (hard reset, Airplane Mode, etc…) The only fix I found was going into settings and Reset Network Settings. Totally sucks but that is basically what I have to do. T-Mobile rep said he did something on his end too, but didn’t fix the issue when it came back.

Meanwhile, several Telstra customers in Australia report that Visual Voicemail no longer works after updating to iOS 10 and installing the latest carrier update. “I have no indication that a voicemail has been left and nothing shows up in the voicemail section,” wrote one user. “Voicemails are definitely being left though.”

It is unclear if Apple is aware of these issues, but they will likely be resolved in a future software or carrier update.

Tags: T-Mobile, Telstra

Discuss this article in our forums

You can follow on Twitter or join our Facebook page to keep yourself updated on all the latest from Apple and the Web.