Twitterrific developer Craig Hockenberry has posted the results of an interesting survey he performed over on his blog. Hockenberry was deep into the development cycle of getting his apps ready for iOS 7 when he wondered if many other developers out there are doing what he’s doing — that is, dropping support for any version of iOS below iOS 7. So Hockenberry ran an informal survey and discovered some interesting things. Out of 575 responses:

  • 95% of developers said they are working on updating their apps for iOS 7.
  • 52% of developers said they will drop support for any iOS below iOS 7 in the next major version of their app.

The first finding isn’t surprising, as developers are keen to be on Apple’s latest iOS. However, the second finding is a bit shocking, but that’s a reflection of the work developers need to undertake to make sure their apps run fluidly and look good on iOS 7. What this means for users is that most apps are going to have an iOS 7 look and feel so they will get a continued uniformity on their iOS devices. However, those users with older devices that don’t support iOS 7 may find that it’s time to upgrade or else some of their favorite apps may leave them behind.

Over half of surveyed developers will require iOS 7 for their apps originally appeared on TUAW – The Unofficial Apple Weblog on Mon, 05 Aug 2013 11:00:00 EST. Please see our terms for use of feeds.

Source | Permalink | Email this | Comments

You can follow on Twitter or join our Facebook page to keep yourself updated on all the latest from Apple and the Web.