F0recast: Easiest Way To Find Out iPhone 3GS Bootrom Version

F0recast iPhone 3GS Bootrom VersionThough there are tools that make it easy to jailbreak iPhone, things have got a lot more complicated and confusing with the release of iOS4 and updated boot ROM in iPhone 3GS models.

We had published a step-by-step guide on how to find out iPhone 3GS bootrom version. But as some of our readers have pointed out there is an easier way to find out without putting your iPhone 3GS in DFU mode.

iH8sn0w, developers of popular jailbreaking tool, Sn0wbreeze had released a tool called F0recast for iPhone OS 3.1.3 to find out if your iPhone 3GS can be jailbroken with or without tethering and whether your iPhone can be unlocked.

F0recast also gives the information such as the serial number, baseband version, bootloader version and model number of your iPhone.

However, iH8sn0w hasn’t updated F0recast for iOS 4 so information about jailbreaking, unlocking is not very accurate.

But you can easily find out if iPhone 3GS has older or newer bootrom using F0recast.

All you need to do is connect your iPhone 3GS to the computer and launch F0recast:

Mac Users:

F0recast for Mac will let you know if iPhone 3GS can be ‘Untethered’ (as seen in the screenshot below). If it is ‘Yes’ then your iPhone 3GS has the older bootrom. iPhone 3GS has the new bootroom if it is ‘No’.

F0recast iPhone 3GS Bootrom Version

Note: F0recast should be used only to find out iPhone 3GS bootrom version for now as it hasn’t been updated for iOS 4 and the related progress on jailbreaking and unlocking it so the information such as ‘Jailbreakable’, ‘Unlockable’ is not completely accurate.

Windows Users:

F0recast for Windows will let you know if iPhone 3GS can be ‘Tethered’ (as seen in the screenshot below). If it is ‘No’ then your iPhone 3GS has the older bootrom. iPhone 3GS has the new bootroom if it is ‘Yes’.

F0recast iPhone 3GS Bootrom Version

Note: F0recast should be used only to find out iPhone 3GS bootrom version for now as it hasn’t been updated for iOS 4 and the related progress on jailbreaking and unlocking it so the information such as ‘Jailbreakable’, ‘Unlockable’ is not completely accurate.

The requirements for the application to run properly include .Net Frameworks 2.0 or higher, and iTunes 9.0 or higher for Windows users and iTunes 9.0 or higher for Mac users.

You can download the latest version of F0recast for free here.

You can follow iPhoneFirmware.com on Twitter, add us to your circle on Google+ or like our Facebook page to keep yourself updated on all the latest from Apple and the Web.