PSA: Slack dropping support for Apple devices running iOS 12 as of next month

The popular business communication platform Slack will soon stop working on some Apple devices. According to the company, the Slack app for iOS will soon require iOS 13, which will result in the end of support for devices such as the iPhone 5s and first-generation iPad Air.

In the release notes for the latest version of the Slack app available on the App Store (21.08.20), the company confirms that this is the latest app update for Apple devices running iOS 12. As of September 1, when Slack is expected to introduce another update to its iOS app, the platform will no longer work on older devices.

This will be the last version of Slack that supports iOS 12, which means this is the last version that supports devices such as iPhone 5s and 6, iPad Mini 2 and 3, iPad Air (1st generation), and iPod Touch (6th generation).

In addition, starting on September 1st, you’ll need to be running iOS 13.3 or later in order to connect to Slack. We know this is potentially frustrating news, but these minimum requirements are necessary in order to ensure Slack remains as secure and seamless as we built it to be. Thank you for your understanding.

You can check the list of affected devices below:

  • iPhone 5s
  • iPhone 6
  • iPhone 6 Plus
  • iPad Air (1st gen)
  • iPad mini 2
  • iPad mini 3
  • iPod touch (6th gen)

Today’s Slack update fixes some bugs, including an issue with Apple’s VoiceOver. You can download Slack for free on the App Store.

FTC: We use income earning auto affiliate links. More.

Check out 9to5Mac on YouTube for more Apple news:


You can follow iPhoneFirmware.com on Twitter, add us to your circle on Google+ or like our Facebook page to keep yourself updated on all the latest from Apple and the Web.